commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject Re: [COMPRESS] Changeset ideas
Date Mon, 30 Mar 2009 04:08:38 GMT
your API suggesteions sound useful.

On 2009-03-30, sebb <> wrote:

> On 29/03/2009, sebb <> wrote:
>> On 29/03/2009, sebb <> wrote:
>>> The current ChangeSet API allows for:
>>>> deletion of entries by name

> The same method call is currently used for both deleting a single
> file, and for deleting a directory tree. If the string matches a file,
> it is deleted, but if it happens to match a directory name, then the
> directory and any contents are deleted.

> Both of these are useful functions, but I think they should have
> different method calls to avoid accidents.

Agreed, delete and deleteTree or something similar.

>> Forgot about "Move", which is not yet implemented.

>>  I think that should be called "Rename", unless it really means to move
>>  the entry elsewhere in the file.

Agreed as well.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message