commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Carman <ja...@carmanconsulting.com>
Subject Re: [LANG] 3.0 JCIP Annotations
Date Fri, 20 Mar 2009 17:52:48 GMT
On Fri, Mar 20, 2009 at 1:50 PM, sebb <sebbaz@gmail.com> wrote:
>
> Take 2:
>
> Just found a problem when using compile+optional in HC:
>
> The generated bundle:
> org.apache.httpcomponents.httpcore_4.1-SNAPSHOT.jar
> contains a valid DEPENDENCIES file.
> The MANIFEST looks OK too, no mention of jcip
>
> However, the included archive:
> httpcore-nio-4.1-SNAPSHOT.jar
> has a DEPENDENCIES file which refers to JCIP.
>
> Not sure if this is a problem for OSGI or not, but it is not consistent.

Ok, I understand that we want to make sure OSGi bundles work
correctly.  But, misusing maven's dependency declaration because one
specific plugin doesn't work properly with the correct way to do it
doesn't seem right to me.  How about we fix the felix plugin?  Or,
can't we tell it to ignore that stuff somehow via configuration?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message