commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Fabulich <...@fabulich.com>
Subject [DBUTILS] Version numbering (was: Java version not specified in POM)
Date Sat, 07 Mar 2009 22:45:11 GMT
Good catch.  :-(

Uh, if dbutils 1.1 was compatible with java 1.3, and we want to depend on 
java 1.4 in the next version, do we have to call it "dbutils 2.0"?

I assume not; I think we can still call it "dbutils 1.2" even though we 
depend on java 1.4 now.  Is that OK?

Similarly, could/should we call the java5 version "1.3"?  That would 
certainly save time on branch management...?

sebb wrote:

> The pom.xml does not specify a java source or target version, so
> defaults to 1.3 (from the parent pom)
>
> As far as I can tell, the component requires at least 1.4 so the POM
> needs to be updated.
>
> [IMO the compiler settings should never be delegated to the parent POM]


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message