commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Liam Coughlin <lscough...@gmail.com>
Subject Re: [DBUTILS] Version numbering
Date Sun, 08 Mar 2009 14:50:13 GMT
the code NEEDS to change though, and not in a backwards compatible way.  Do
whatever is appropriate with version numbers to indicate that non-binary
compatible changes are coming.

Cheers,
-L

On Sun, Mar 8, 2009 at 6:04 AM, Stephen Colebourne <
scolebourne@btopenworld.com> wrote:

> Dan Fabulich wrote:
>
>> Henri Yandell wrote:
>>
>>  The Java5 version is more up for debate. If the API is no longer
>>> compatible, then we start to lean to 2.0. Especially as calling it 2.0
>>> allows for more of an overhaul of API.
>>>
>>
>> The the API in the "java5" branch is backward compatible; the generics and
>> varargs are erased at compile time.  Of course, the code has to be compiled
>> with target=1.5, but on a Java 1.5 VM you could swap it in and not notice
>> the difference.
>>
>
> Check javap method signatures, or use clirr.
>
>
> Stephen
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message