commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <tcu...@apache.org>
Subject Re: [compress] Which Java version to use?
Date Wed, 04 Feb 2009 08:12:08 GMT
Yeah, I would think it safe to say we target 1.4+. I would even
consider going 1.5+. But it doesn't really help the API much IMO.

cheers
--
Torsten

On Wed, Feb 4, 2009 at 06:42, Christian Grobmeier <grobmeier@gmail.com> wrote:
> Hi
> there is no official baseline, but we use some 1.4 features in
> compress and we didn't feel the urgent need to optimize for 1.1. I
> would say go for it.
>
> Cheers
> Christian
>
> On Wed, Feb 4, 2009 at 6:11 AM, Stefan Bodewig <bodewig@apache.org> wrote:
>> Hi all,
>>
>> I've just merged two changes made to the Ant zip code base -
>> commons-compress' great-grand-parent - into the sandbox and intend to
>> keep doing this as we make changes in Ant.
>>
>> There is another change in Ant that may lead to a tiny performance
>> improvement by using JDK 1.4 collections (LinkedHashMap) instead of
>> Java 1.1 ones.  I'm not sure whether I can savely merge this or
>> whether commons-compress intends to target JVMs < 1.4.
>>
>> Is there some sort of official baseline?
>>
>> Stefan
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message