commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <flame...@gmail.com>
Subject Re: [io] Version for Java 1.4
Date Sun, 08 Feb 2009 19:54:20 GMT
On Sun, Feb 8, 2009 at 5:04 AM, Niall Pemberton
<niall.pemberton@gmail.com> wrote:
> On Fri, Feb 6, 2009 at 2:19 PM, Jukka Zitting <jukka.zitting@gmail.com> wrote:
>> Hi,
>>
>> Commons IO trunk is already using Java 5 features (which is nice), but
>> I was wondering about how we can make the next IO release usable in
>> environments that still run Java 1.4. For example I've just added a
>> few extra classes (see IO-192 and IO-193) that I'd like to start using
>> in projects like Apache Jackrabbit that still target Java 1.4 as the
>> base platform.
>>
>> One option that we use in Apache Tika is the Maven retrotranslator
>> plugin. It produces an extra retrotranslated version of the jar
>> artifact for use in Java 1.4 environments. Another option is to
>> maintain a separate branch for a Java 1.4 (or older) version of
>> Commons IO.
>> Any thoughts on this?
>
> We created a branch before the Java 1.5 changes were started:
>
> http://svn.apache.org/viewvc/commons/proper/io/branches/IO_1_4_BRANCH/
>
> I think the new Java5 stuff in trunk should be released as IO 2.0 - so
> we could release a IO 1.5 version that is for JDK 1.4. Having said
> that JDK 1.4 is so old now I don't really think we should bother
> supporting it and just focus on getting a release of the latest stuff
> out.

+1.  1.4 is too dead, move JackRabbit off it ;)

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message