commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luc Maisonobe <Luc.Maison...@free.fr>
Subject Re: [math] redesigning the optimization/estimation packages
Date Wed, 14 Jan 2009 22:01:36 GMT
Ted Dunning a écrit :
> The standard term in mathematical software is solver for the object that
> does it, solve for the method it does and root or result for the final
> output.
Thanks for the hint, Ted.
Hence I guess for the package name, "solvers", "solving", "root"/"roots"
are all acceptable.
For the other package "minimizers" is perhaps awkward but "minimization"
or "minimum"/"minima" are also acceptable.

Lets go for "root" and "minimum" as suggested by Gilles.

Luc

>
> (and I am a native English speaker)
>
> On Wed, Jan 14, 2009 at 12:08 PM, Luc Maisonobe
> <Luc.Maisonobe@free.fr>wrote:
>
> >> I think that "root" is clearer (e.g. for a new user browsing the
> package
> >> list javadoc).
> >> [And both are little bit shorter names than the alternative. ;-)]
> > I am OK with any suggestion like this. Since I'm not a native english
> > speaker, I let some time for other people to express their feelings
> > about this.
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message