commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <>
Subject Re: [math] redesigning the optimization/estimation packages
Date Wed, 14 Jan 2009 23:27:02 GMT

> > > The standard term in mathematical software is solver for the object that
> > > does it, solve for the method it does and root or result for the final
> > > output.

In my opinion, "rootfinders" and "minimumfinders" are clearer; hence the
suggestion "root" and "minimum" for a short but unambiguous Java package

Also, I would think that, in mathematics (perhaps even more in software),
there are many things called "solver". ;-)
The package naming is supposed to help the user find its way towards the
classes (s)he is looking for.

>From another point-of-view, I always wonder how helpful it is to have a
package named "solver" (for example) and find that it contains classes
like "FooSolver" and "BarSolver". Why not just have "Foo" and "Bar" then?
I know that this could possibly lead to names clashing; hence I actually
don't suggest to remove the "Solver" suffix for the classes in that package.
But already having that (mathematically correct) suffix, for the classes and
interfaces, enables the developer to provide an *additional* hint to the
user, with the package name.


P.S. I wouldn't fight over these name changes but since the refactoring was
     already suggested, I thought that this argument might have some value.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message