commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Akolkar" <rahul.akol...@gmail.com>
Subject [digester] 2.0 release
Date Fri, 19 Dec 2008 23:31:56 GMT
Its been 2 years since the last [digester] release. I propose we move
towards a v2.0.

The breaking change will be requiring JDK 1.5 to pick up some of the
improved SAX parser capabilities. I am interested in support for XML
Schema and XInclude, which would be very handy in [scxml] (actually,
necessary even). Also, I'm not the only one hitting the wall -- see
related ongoing thread on user list.

Apart from the JDK requirement, no other breaking changes will be
introduced. I do not intend to make other changes, even general JDK
1.5 improvements. If anyone else has other fixes and enhancements in
mind, I suggest they be applied now, or you indicate how much time you
expect to need. I'd like to proceed quickly, since time will get
tighter beyond the holidays.

I intend to branch current trunk to 1_X and make trunk 1.5-based.

Thoughts? If there are no comments over the weekend, I'll start making changes.

-Rahul

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message