commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Dunning" <>
Subject Re: [math] Matrix decomposition API
Date Fri, 05 Dec 2008 19:56:49 GMT
Is there really any point in separating out the QRSolver?  Is it because we
expect multiple QR decomposition implementations that could share the same
solving code?

If that is really necessary, why not just have AbstractQRDecomposition that
has a solve method?

Then the user sees this:

 RealVector solution = new QRDecomposition(... args... ).solve(constant);

This is even simpler and makes much more sense to the user.

On Fri, Dec 5, 2008 at 2:25 AM, <> wrote:

>  RealVector solution = new QRSolver(new QRDecomposition()).solve(constant);

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message