commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Carman" <ja...@carmanconsulting.com>
Subject Re: [lang] Java 5
Date Thu, 12 Jun 2008 15:20:10 GMT
Yes, of course! :)  But, who does that anymore? ;)  I'm kidding of
course.  I know that some vendors only support JDK 1.4 currently.

On Thu, Jun 12, 2008 at 11:16 AM, Ralph Goers
<Ralph.Goers@dslextreme.com> wrote:
>
>
> James Carman wrote:
>>
>> On Thu, Jun 12, 2008 at 10:45 AM, Ralph Goers
>> <Ralph.Goers@dslextreme.com> wrote:
>>
>>
>>>
>>> This confuses me. Doesn't the fact that since the code will no longer run
>>> on
>>> a pre-1.5 JDK mean that compatibility is broken, even if not a single
>>> line
>>> of code changes? (Yes - I know that we technically only release source so
>>> in
>>> that case it could be recompiled, but I work with Maven). In any case, I
>>> expect that the code will only compile with a 1.5 compiler anyway.
>>>
>>>
>>
>> Just because the new Commons Lang is compiled against 1.5 doesn't mean
>> that older code that depends on it won't be able to use it.
>>
>>
>
> It does if that older code is trying to run in a 1.4 or 1.3 JVM.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message