commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: [math] should version 2.0 be targeted to Java 5 ?
Date Thu, 15 May 2008 23:50:46 GMT
On Fri, May 16, 2008 at 12:26 AM, Emmanuel Bourg <ebourg@apache.org> wrote:
> sebb a écrit :
>
>> However AFAICS "jar hell" could still apply to those unknown projects,
>> and needs to be avoided if at all possible.
>
> Well, the probability of jar hell with Commons Math is near zero, I would
> not annoy all the users with a package change for a very hypothetical issue.
> When you look at the dependencies on lang [1] or collections [2] you
> understand why these components must adopt a very careful approach, but
> [math] is nowhere near this situation.

+1, IMO the approach chosen should be decided on a
component-by-component basis and I don't have a problem with breaking
compatibilty in a major version of Math, without changing package
names, if thats what the Math devs want to do.

Niall

> Emmanuel Bourg
>
> [1] http://mvnrepository.com/artifact/commons-lang/commons-lang/2.1
> [2]
> http://mvnrepository.com/artifact/commons-collections/commons-collections/3.2

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message