commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Bourg <ebo...@apache.org>
Subject Re: [math] should version 2.0 be targeted to Java 5 ?
Date Thu, 15 May 2008 16:44:40 GMT
Phil Steitz a écrit :

> Regarding package renaming, there are very few backward incompatible
> changes lined up for 2.0, and all of the proposed 1.5-dependent stuff
> is new, so I am hesistant to do a wholesale change.  What would be the
> problem with renaming only packages that contain classes with
> incompatible changes?

On the other hand, a new package may not be needed at all. I checked on 
mvnrepository.com the number of open source projects depending on 
Commons Math, and besides a beta version of JET from Codehaus, there is 
none. That means slight incompatible changes in the 2.0 API are unlikely 
to cause a dependency havoc across hundred of projects.

Emmanuel Bourg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message