commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell" <flame...@gmail.com>
Subject Re: [VOTE] Release Lang 2.4 (RC2)
Date Sun, 16 Mar 2008 03:27:07 GMT
Time & effort? :)

1.1 and 1.2 on Linux are painful too. Needs an old linux. Otherwise
you need a Windows machine, which I don't have a spare one of.

Hen

On Sat, Mar 15, 2008 at 1:39 PM, Paul Benedict <pbenedict@apache.org> wrote:
> Henri, why not setup Continuum to run all these jdk versions?
>
>
>
>  On Sat, Mar 15, 2008 at 2:19 PM, Henri Yandell <flamefew@gmail.com> wrote:
>
>  > On Sat, Mar 15, 2008 at 5:32 AM, sebb <sebbaz@gmail.com> wrote:
>  > > On 15/03/2008, Henri Yandell <flamefew@gmail.com> wrote:
>  > >  > Compiling against 1.2, we have only one inconsistency. The enums
>  > >  >  package uses WeakHashMap's Map constructor. That wasn't added until
>  > >  >  1.3. Not that I could get my JDK 1.2.2 install and the Ant 1.5.4
>  > >  >  install to work happily together [or Ant 1.7.0]; however using javac
>  > >  >  by hand showed that the above is the only problem.
>  > >  >
>  > >  >  I'm going to change that code to use the empty constructor and then
>  > >  >  use putAll(Map).
>  > >  >
>  > >  >  I can't download 1.1 currently, Sun's site is down.  However,
>  > >  >  WeakHashMap wasn't available until 1.2 and I don't see us changing
>  > >  >  that. So despite the target JDK of 1.1, we are 1.2 dependent in
>  > >  >  reality.
>  > >  >
>  > >
>  > >  I downloaded 1.1 and 1.2 OK yesterday to see if I could test with them.
>  > >
>  > >  But I could not get them to work with Ant (maybe I was using the wrong
>  > >  version - I tried 1.6.0 with Java 1.2.2). "ant -version" works, but
>  > >  "ant -p" says:
>  > >
>  > >  A nonfatal internal JIT (3.10.107(x)) error 'chgTarg: Conditional' has
>  > >  occurred in :
>  > >   'org/apache/tools/ant/Project.addReference
>  > >  (Ljava/lang/String;Ljava/lang/Object;)V': Interpreting method.
>  >
>  > I got the same thing, with both 1.5.4 [which claims to work with JDK
>  > 1.1, so surely it works with JDK 1.2] and 1.7.0.
>  >
>  > >  What did you use for testing with 1.2? Just curious.
>  >
>  > cd src\java\
>  > javac org\apache\commons\lang\*.java
>  >
>  > and then repeated for the other packages :) There is no spoon.
>  >
>  > Hen
>  >
>
>
> > ---------------------------------------------------------------------
>  > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>  > For additional commands, e-mail: dev-help@commons.apache.org
>  >
>  >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message