commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: [VOTE] Release version 1.0 of commons-build-plugin based on RC1
Date Wed, 20 Feb 2008 17:50:38 GMT
On Feb 20, 2008 5:35 PM, sebb <sebbaz@gmail.com> wrote:
> On 20/02/2008, Niall Pemberton <niall.pemberton@gmail.com> wrote:
> > On Feb 20, 2008 3:56 PM, sebb <sebbaz@gmail.com> wrote:
> >  > On 19/02/2008, Niall Pemberton <niall.pemberton@gmail.com> wrote:
> >  > > I'd like to release commons-build-plugin.
> >  > >
> >  > >  Artifacts available for review are here:
> >  > >  http://people.apache.org/~niallp/cbp-1.0-rc1/
> >  > >
> >  > >  SVN Tag:
> >  > >  http://svn.apache.org/viewvc/commons/proper/commons-build-plugin/tags/commons-build-plugin-1.0-RC1/
> >  > >
> >  > >  Site:
> >  > >  http://people.apache.org/~niallp/cbp-1.0-rc1/site/
> >  >
> >  > The dependency page looks a bit odd - does the plugin really require
> >  > all those jars?
> >
> >
> > I guess so, but the only specified dependencies are maven-script-ant,
> >  ant and ant laucher - so the rest are "inherited"
>
> I just tried running mvn site:site and it generated a very different
> page - only ant, ant-launcher and maven-script-ant were listed as
> proper dependencies - the rest were shown as transitive dependencies.
> This is as I would expect.
>
> The site in your home directory seems to have merged the two and
> listed all dependencies twice.
>
> Also my version of the page does not have the Java section.

OK I blame you for this ;)

I have  a local copy of the maven-project-info-reports-plugin which I
patched and submitted as an enhancement to show the java version you
asked for on other releases. I'll re-generate with the latest release
version.

> >  http://svn.apache.org/repos/asf/commons/proper/commons-build-plugin/trunk/pom.xml
> >
> >
> >  > In particular, does it use JUnit, given that there aren't any java files?
> >
> >
> > no, but see above
> >
> >
> >  > The Java version information is a bit misleading, as no Java is involved.
> >  > Also, for the plugin to actually be used presumably requires Java 1.4+
> >  > as it is a Maven2 plugin?
> >
> >
> > True, but this is inherited from commons-parent...
>
> But it can (and should) be overridden for projects that require
> different versions.

Right, but this is a plugin for internal commons use that runs ant,
not java - so while it is *noise* it doesn't really matter - I'll
change this in trunk though.

> >  > Not much point in having a JDepend report either...
> >
> >
> > Agreed, but this is inherited from commons-parent...
> >
>
> I thought the idea of Commons Parent was to define all the appropriate
> plugins and allow sub-projects to use whatever plugins are needed by
> them?
>
> Is it really not possible to override the reports section?

Not that I can see - you can include/exclude the standard reports -
but if a report is defined in the reporting section I can't see a
global way to say "don't run it" - there may be options on individual
reports (e.g. I think surefire has one) for this - but jdepend doesn't
seem to.

Niall

> >  > BTW, the "Goals" link in the navigation panel does not work properly.
> >  > This is probably because its "href" attribute is empty.
> >  > Perhaps that's a known bug?
> >
> >
> > OK I'll take a look, but the site isn't part of the release - I made
> >  it available because it helps anyone not familiar with maven ant
> >  plugins to see how it works - also I hope that the fact there is some
> >  docs on how to maintain it gives people some confidence about
> >  releasing it.
> >
> >
> >  Niall
> >
> >
> >  > >
> >  > >  [  ] +1  go ahead and release
> >  > >  [  ] -1   No, because...
> >  > >
> >  > >  Niall
> >  > >

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message