commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject [io] 2.0 Moving to minimum of JDK 1.5
Date Tue, 05 Feb 2008 04:47:20 GMT
We've discussed moving to a minimum of JDK 1.5 for IO 2.0 previously -
theres also an JIRA report here:
   http://issues.apache.org/jira/browse/IO-140

>From memory the preference was to move to a new package name  - how
about "org.apache.commons.io2"?

Are there any objections to me creating an IO 1.4 branch from the
current trunk and then starting work on IO 2.0 in the trunk.

Initial plans would be:

 - rename to the new package
 - remove deprecated items
 - Making appropriate JDK 1.5 changes (generics, using StringBuilder
and new Appendable for Writers etc).

Niall

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message