commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Bourg <ebo...@apache.org>
Subject Re: [configuration] JDK compatibility
Date Thu, 14 Feb 2008 17:13:05 GMT
Hi all,

I'm a bit late in this discussion, I'm quite favorable to an upgrade of 
the minimum JDK required, JDK 1.3 compatibility is really handicapping 
nowadays. I just hope this doesn't imply designing a new configuration 
API based on the current code, or this could turn into another cli2 like 
never finished project.

Regarding the new package name, I prefer org.apache.commons.config 
rather than org.apache.commons.configuration2. It's shorter, still 
meaningful and version independent (I hope we'll not need another 
package change anytime soon!).

Emmanuel Bourg


Oliver Heger a écrit :
> (There was a similar discussion about commons lang recently.)
> 
> Configuration used to support JDK 1.3. For the next release (either 1.6 
> or 2.0) I would like to drop this compatibility. The number of feature 
> requests that require a newer JDK version is increasing.
> 
> This raises a couple of questions:
> - To which JDK version should we switch? 1.4 or immediately to 1.5?
> - Should creating a compatibility branch be considered? (I doubt that 
> there is enough energy and motivation for maintaining multiple branches.)
> - Does a switch in the JDK version require a major release?
> - Is a new package name required (at least for a major release if there 
> are binary incompatible changes)?
> 
> Any thoughts?
> 
> Oliver
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message