commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorbjørn Ravn Andersen <thunderax...@gmail.com>
Subject Re: [io] 2.0 Moving to minimum of JDK 1.5
Date Wed, 06 Feb 2008 16:39:10 GMT
Stephen Colebourne skrev  den 06-02-2008 12:00:
>
> IMO, Java 5+ is almost a different language to pre Java 5. The fact that the Java community
has taken ages to move up is a sign of this.
>   
I believe that the sole reason for this is that Sun chose to enforce 
that Java 5 could only compile to bytecode that could not run with 
earlier versions of Java.

Had they made the generics stuff compatible it would have been 
universally adopted by now.

In my opinion :)

-- 
  Thorbjørn

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message