commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: [IO] IO 1.4 on Java 1.3 , IO 1.5 on Java 1.4
Date Thu, 10 Jan 2008 19:48:11 GMT
On Jan 10, 2008 6:14 PM, Gary Gregory <GGregory@seagullsoftware.com> wrote:
> Hello:
>
> I would like to propose simplifying the code and current release by:
>
> - Keeping IO 1.4 on Java 1.3 only. This means removing the Java 1.4 conditional code
execution.

There isn't any conditional code execution - just four classes that
use Java 1.4 features - the rest is 1.3 compatible. We did discuss
this a couple of times - the latest here:

  https://issues.apache.org/jira/browse/IO-127

I'm -1 to your propoal at this stage and for keeping what we have
which IMO is ready to release as it is now - just need to update the
docs and cut an RC. I was hoping/planning to do that in the next day
or so.

Niall

> - Setting the requirement for IO 1.5 on Java 1.4, allowing NIO implementations at will.
>
> Thoughts? Is this something we should [vote] on?
>
> Thanks,
> Gary

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message