commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: [site] Odd m2 site build
Date Tue, 04 Sep 2007 18:17:57 GMT
This is a well-known oddity. Maven's site-plugin will try to resolve all 
urls into relative urls, if it can. This is waht is happening to your 
logo here.

The release version of the site-plugin has not changed in quite a while. 
We should lock the version of the site-plugin, if that hasn't been done.

Phil Steitz wrote:
> This may be a local problem on my end, but I am having trouble getting
> the m2 site generation to work for DBCP.  The current live site was
> generated using m2 and commons-parent 3.  The oddness is in the html
> source for the parent logo that I now get when generating the site
> locally.  I get this in the generated html source:
> 
> <div id="banner">
>  <a href="../" id="bannerLeft">
>  <img src="../images/logo.png" alt="" />
>   </a><a href="index.html" id="bannerRight">
>    <img src="images/dbcp-logo-white.png" alt=""/>
>     </a>
>  <div class="clear">
>   <hr/>
>  </div>
> 
> I don't get why it is putting in a relative path for the parent logo.
> 
> I notice that we do not specify the version of the site plugin in
> commons-parent, which should be fixed, but I don't think the release
> version has changed since the live site was generated.
> 
> Any ideas what could be causing this?
> 
> Phil
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 
> 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message