commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michiel Kalkman" <michielgkalk...@gmail.com>
Subject Re: [continuum] BUILD FAILURE: Commons Configuration
Date Wed, 29 Aug 2007 06:27:29 GMT
Maybe Continuum should be running headless, as other projects might
also try to use awt code in the future.

Michiel

On 8/29/07, Jörg Schaible <Joerg.Schaible@elsag-solutions.com> wrote:
> Hi Oliver,
>
> Oliver Heger wrote on Tuesday, August 28, 2007 6:32 PM:
>
> > Henri Yandell wrote:
> >> We can change CI to use a JDK 1.6 if that's what Configuration's
> >> target is.
> >
> > This doesn't seem to be the problem. We get errors like the
> > one below.
> > Is there anything wrong with the JDK on the build machine?
> >
> > Oliver
> >
> > testGetConfiguration(org.apache.commons.configuration.TestData
> >   Configuration) Time elapsed: 0.052 sec  <<< ERROR!
> > java.lang.UnsatisfiedLinkError:
> > /usr/lib/jvm/j2sdk1.4.2_15/jre/lib/i386/libawt.so: libXp.so.6: cannot
> > open shared object file: No such file or directory
>
> This might simply be a headless installation ... so no X on the machine at all. Try to
define for surefire the awt.headless system property.
>
> [snip]
>
> - Jörg
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message