commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Zeigermann" <oli...@zeigermann.de>
Subject [all] site generation broken???? (WAS: Struggling with the site update for transaction)
Date Sat, 18 Aug 2007 22:45:28 GMT
Folks!

I have finally managed to make some progress on my "navigation still
points to jakarta" problem and it seems to be it is broken in all
components.

That is really strange as all subcomponent trunks have this DTD

<!DOCTYPE org.apache.commons.menus SYSTEM
'http://commons.apache.org/build/maven-build.dtd'>

Which - among other things - contains that:

http://jakarta.apache.org/commons/build/commons.ent

which is forwarded to

http://commons.apache.org/build/commons.ent

which then contains this

<menu name="Commons" type="footer">
    <item name="Home"
href="http://jakarta.apache.org/commons/" />
    <item name="Components"
href="http://jakarta.apache.org/commons/components.html"
collapse="true">
        <item name="Full list..."
href="http://jakarta.apache.org/commons/components.html"/>
    </item>
    <item name="Sandbox"
href="http://jakarta.apache.org/commons/sandbox/index.html"
collapse="true">
        <item name="Full list..."
href="http://jakarta.apache.org/commons/sandbox/index.html"/>
    </item>
    <item name="Dormant"
href="http://jakarta.apache.org/commons/dormant/index.html"
collapse="true">
        <item name="Full list..."
href="http://jakarta.apache.org/commons/dormant/index.html"/>
    </item>
    <item name="Volunteering"
href="http://jakarta.apache.org/commons/volunteering.html"/>
    <item name="Contributing Patches"
href="http://jakarta.apache.org/commons/patches.html"/>
    <item name="Building Components"
href="http://jakarta.apache.org/commons/building.html"/>
    <item name="Releasing Components"
href="http://jakarta.apache.org/commons/releases/index.html"/>
    <item name="Wiki"
href="http://wiki.apache.org/jakarta-commons/FrontPage"/>
</menu>

which is obviously responsible for the wrong navigation entries. How
was anyone able to generate a sound looking site? Seems impossible
with what is in SVN? Or am I just plain stupid?

Oliver



2007/8/17, Oliver Zeigermann <oliver@zeigermann.de>:
> Hey Dennis!
>
> Thanks for helping :)
>
>  However, I still have this problem. Any other idea? Cleaning maven
> caches and stuff did not help either. I noticed the build also
> succeeds when there is no ../commons-build.
>
> Any other location to define where commons.ent comes from?
>
> Thanks in advance
>
> Oliver
>
> 2007/8/15, Dennis Lundberg <dennisl@apache.org>:
> > The included entity &commons; is fetched from ../commons-build/... in
> > our Maven 1 setup. So you probably need to do "svn update" on that
> > directory to get the latest TLP changes.
> >
> > Zeigermann, Oliver wrote:
> > > Folks!
> > >
> > > I just can't seem to properly update the transaction site. My problem
> > > is that the common links (included by "&commons;" in navigation.xml)
> > > keep on pointing to Jakarta. I jsut can't find the location where I
> > > would have to change that.
> > >
> > > Any hint highly appreciated.
> > >
> > > Thanks in advance
> > >
> > > Oliver
> > >
> >
> >
> > --
> > Dennis Lundberg
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> > For additional commands, e-mail: dev-help@commons.apache.org
> >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message