commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: [configuration]Error result from Test due to build isse.
Date Tue, 14 Aug 2007 18:03:02 GMT
Gene Wu wrote:
> Hi,
> 
> I got some failed results from test class
> "org.apache.commons.configuration.TestDataConfiguration".
> The error is "java.lang.ClassNotFoundException:
> javax.mail.internet.InternetAddress".
> 
> I run build.xml and pom.xml. The error messages are the same. There is no
> javamail dependency in neither pom nor build.
> 
> After I put the following dependency in pom file. Those errors disappeared.
> 
>    <dependency>
>       <groupId>javax.mail</groupId>
>       <artifactId>mail</artifactId>
>       <version>1.4</version>
>       <scope>test</scope>
>     </dependency>
> 
> 
> 
> Could someone check with that? Here is my env info:
> 
> Maven version: 2.0.7
> Java version: 1.5.0_04
> OS name: "windows xp" version: "5.1" arch: "x86"
> 
> Thanks,
> Gene.
This dependency was recently added, but obviously only to the maven 1 
build, which is still our default build system.

I updated the ant and the maven 2 build, so the problem should be 
solved. Thank you for spotting this.

Oliver

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message