commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: [all] TLP Move - release Commons Skin and Parent pom
Date Thu, 02 Aug 2007 09:38:18 GMT
Niall Pemberton wrote:
> On 8/2/07, Niall Pemberton <niall.pemberton@gmail.com> wrote:
>> On 8/1/07, Dennis Lundberg <dennisl@apache.org> wrote:
>>> Sorry I forgot, the commons-parent has a reference to the new wiki
>>> location in its site.xml. So we can't publish sites with either parent
>>> until the new wiki location is working.
>>>
>>> Who has knowledge/karma to start to move the wiki? At least get the
>>> /commons/FrontPage working.
>> I asked this on the TLP jira ticket:
>> http://issues.apache.org/jira/browse/INFRA-1283
>>
>>> Dennis Lundberg wrote:
>>>> Niall Pemberton wrote:
>>>>> Another TODO is release new versions of commons-skin and
>>>>> commons-parent pom
>>>>>
>>>>> Niall
>>>> Status Report
>>>>
>>>> commons-skin
>>>>
>>>> The only thing that has changes is the scm information in the pom, so I
>>>> don't see a reason for a new release of this now.
>>>>
>>>> commons-parent
>>>>
>>>> Version 4-SNAPSHOT has been deployed to the snapshot repository, so if
>>>> you want to try it out go right ahead.
>> I tried it with Commons Validator - couple of issues:
>>
>> 1. The RAT report blew up on an illegal character - this is sorted out
>> in RAT 0.5 and specifying RAT Plugin version 1.0-alpha-2 (which
>> depends on RAT 0.5) in commons-parent sorted that out.
>>
>> 2. Validator site was missing the LHS commons logo - I thought by some
>> clever m2 magic that was picked up from the site.xml in
>> commons-parent. Is that right or do we need to specify a <bannerLeft>
>> element for the Commons logo in each component's site.xml?
> 
> OK, more on this - it is generating the html - but it converts the
> commons logo url to a relative one - so it doesn't work for "offline"
> docs - but presumably would if I published to the right location. IMO
> converting urls to relative ones is a big bug in m2 - it should leave
> them unchanged.

That is a known issue in Maven.

A trick to get around it is to do:

  mvn site:stage

which will create a "complete" site on your local machine, including the 
images, in target/staging/...

> 
> Niall
> 
>> Niall
>>
>> P.S. thanks for doing all this
>>
>>>> commons-sandbox-parent
>>>>
>>>> Version 2-SNAPSHOT has been deployed to the snapshot repository, so if
>>>> you want to try it out go right ahead. I'm going to go through the
>>>> sandbox components tomorrow and try to update their sites using this
>>>> SNAPSHOT version.
>>>>
>>> --
>>> Dennis Lundberg
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message