commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Speakmon" <bspeak...@apache.org>
Subject Re: Email Maven 2 Build failing under jdk 1.4?
Date Tue, 19 Jun 2007 05:33:23 GMT
It's not picking up the java14 classifier on subethasmtp-smtp. Apparently
the classifier doesn't propagate to the parent. I really need to get in the
habit of removing my repository before signing off a pom.

Fix checked in.

On 6/18/07, Dion Gillard <dion@trongus.com> wrote:
>
> Is this right?
>
> When running mvn clean install on the current email trunk, I get:
>
> [INFO] Compilation failure
> C:\Documents and Settings\Dion
>
> Gillard\workspace\email\src\test\org\apache\commons\mail\BaseEmailTestCase.java:[497,-1]
> cannot access org.subethamail.smtp.server.SMTPServer
> bad class file: C:\Documents and Settings\Dion
> Gillard\.m2\repository\org\subethamail\subethasmtp-smtp\1.2\subethasmtp-s
> mtp-1.2.jar(org/subethamail/smtp/server/SMTPServer.class)
> class file has wrong version 49.0, should be 48.0
>
>
>
> C:\Documents and Settings\Dion
>
> Gillard\workspace\email\src\test\org\apache\commons\mail\BaseEmailTestCase.java:[497,-1]
> cannot access org.subethamail.smtp.server.SMTPServer
> bad class file: C:\Documents and Settings\Dion
> Gillard\.m2\repository\org\subethamail\subethasmtp-smtp\1.2\subethasmtp-s
> mtp-1.2.jar(org/subethamail/smtp/server/SMTPServer.class)
> class file has wrong version 49.0, should be 48.0
>
>
> Which means it can only build with 1.5. Is there some magic command
> line trickery I need to get it to build under 1.4?
>
> --
> dIon Gillard
> Rule #131 of Acquisition: Information is Profit.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message