commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell" <flame...@gmail.com>
Subject Re: [cli] Minimum JDK version for 1.1?
Date Wed, 06 Jun 2007 23:20:33 GMT
Yeah, Checkstyle seem big enough to not want to mess with their
dependencies for a bugfix release.

So I guess we need to figure out the broken build.xml under 1.3. Given
that the website will come from Maven1, might just be that the
junitreport bit can be yanked out (if that's the bit that causes the
need for an xml api). Though I don't get why the xml-api I had wasn't
working for it.

You're still finding issues Brian, do you think we should hold off or
do you think the current set of issues are it for the moment?

Hen

On 6/6/07, Brian A. Egge <brianegge@yahoo.com> wrote:
> I think we need to keep the JDK at 1.3.  CheckStyle uses commons CLI and their minimum
is 1.3.  There's probably some other projects which use CLI and still support JDK 1.3.
>
> Maybe we could make CLI2 require JDK 1.5.
>
> -Brian
>
> Rahul Akolkar <rahul.akolkar@gmail.com> wrote: On 6/5/07, Henri Yandell  wrote:
> > I'd like to move the minimum JDK version for CLI up to 1.4 for the CLI
> > 1.1 release.
> >
>
>
> Sounds good to me.
>
> -Rahul
>
>
> > This would:
> >
> > a) Allow the fact that the build.xml does not work on 1.3 to be ignored.
> > b) Allow CLI-131 to be applied.
> > c) Make for an easier build - I can build directly in Maven and not
> > worry about legacy.
> >
> > Anyone against?
> >
> > Hen
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message