commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: [IO] Move to a minimum of JDK 1.4?
Date Fri, 18 May 2007 09:28:17 GMT
On 5/18/07, Stephen Colebourne <scolebourne@btopenworld.com> wrote:
> My preference would be to support JDK1.3 and JDK1.5 versions, rather
> than JDK1.4.

When you say "support" do you mean two active versions under
development or the moving the main development to JDK 1.5 with a JDK
1.3 branch mainly for bug fixes?

I don't have a problem with moving to JDK 1.5 - but are you talking
evolutionary or revolutionaty (i.e. binary incompatible, package name
change etc.) here? Like Jochen IMO it would be better if you expand on
your intention.

> If desired, these calls can be implemented using reflection, so they
> work on JDK1.4 but not on JDK1.3.

They could, but Its not something I'd be interested in doing.

Niall

> Stephen
>
>
> Niall Pemberton wrote:
> > There are a couple of Jira tickets which require JDK 1.4
> >
> > IO-74[1] - Regular Expression IOFileFilter implementation
> > IO-77[2] - FileUtils.move() method that uses NIO
> >
> > Are there any objections to moving Commons IO's minimum requirement to
> > JDK 1.4 for Commons IO 1.4?
> >
> > Niall
> >
> > [1] https://issues.apache.org/jira/browse/IO-74
> > [2] https://issues.apache.org/jira/browse/IO-77

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message