commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] Created: (MATH-165) Simplify use of "EstimationProblem"
Date Fri, 18 May 2007 09:55:16 GMT
Simplify use of  "EstimationProblem"

                 Key: MATH-165
             Project: Commons Math
          Issue Type: Improvement
            Reporter: Gilles
            Priority: Minor

The use of the "EstimationProblem" interface could be simplified by providing a helper (abstract)
class that would implement
the "getMeasurements" "getAllParameters" and "getUnboundParameters" methods.  Currently, each
new implementation of the interface has to do it even if they are typically only called from
the "Estimator" class (and not by the user code).
That same helper class could also take care of storing the partial derivatives.

A skeleton for the requested class could be as follows:

public abstract class SimpleEstimationProblem
    implements EstimationProblem {

    // ... storage for measurements and partial derivatives ...
    protected void addParameter(EstimatedParameter p,
                                ComputableFunction partial,
                                boolean isBound) {
         // ...
    protected void addParameter(EstimatedParameter p,
                                ComputableFunction partial) {
        addParameter(p, partial, false);
    protected double getPartial(EstimatedParameter p,
                                double x) {
        // ...
    protected void addMeasurement(WeightedMeasurement m) {
    public WeightedMeasurement[] getMeasurements() {
        // ...
    public EstimatedParameter[] getAllParameters() {
        // ...
    public EstimatedParameter[] getUnboundParameters() {
        // ...


This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message