commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <tcu...@apache.org>
Subject Re: [all] docs on doing maven2 releases
Date Tue, 03 Apr 2007 22:22:14 GMT
So I got further. So it looks like this

   mvn -Prc release:prepare
   mvn -Prc release:perform -Dgpg.passphrase=... -Darguments="- 
Dgpg.passphrase=..."

almost does the job. Builds and prepares the whole thing. Even does  
the upload BUT
...I cannot find the artifacts in the remote repo (but in my local  
one). Looking at the output

     ...
     [INFO] [deploy:deploy]
     altDeploymentRepository = null
     Uploading: /org/apache/commons/commons-jci-core/1.0-RC1/commons- 
jci-core-1.0-RC1.jar
     4/26K
     8/26K
     12/26K
     16/26K
     20/26K
     24/26K
     26/26K
     26K uploaded
     [INFO] Retrieving previous metadata from dummy
     [INFO] Uploading repository metadata for: 'artifact  
org.apache.commons:commons-jci-core'
     [INFO] Retrieving previous metadata from dummy
     [INFO] Uploading project information for commons-jci-core 1.0-RC1
     Uploading: /org/apache/commons/commons-jci-core/1.0-RC1/commons- 
jci-core-1.0-RC1-sources.jar
     4/28K
     8/28K
     12/28K
     ...

and the parent POM

   http://repo1.maven.org/maven2/org/apache/commons/commons-parent/2/ 
commons-parent-2.pom

it looks like the repository from the profile is not getting  
selected. Instead the artifacts are getting copied in the default  
'dummy' one. Plus I am not seeing any gpg processing. Somehow seems  
the profile is getting ignored.

Am I just too tired and should hit the sack ...or what am I missing?

cheers
--
Torsten


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message