commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [VOTE] Release Commons Transaction 1.2
Date Sun, 07 Jan 2007 01:46:10 GMT
Joerg Heinicke <joerg.heinicke <at> gmx.de> writes:

> > The ant build only seems to work for JDK 1.3 when the geronimo jars
> > are overriden with the sun ones and doesn't work for me for JDK 1.4
> 
> Yes, it stands and fails with the correct jee jars as I wrote recently [1].

Works now with 1.3 compiled Geronimo jars. Created them by checking out the
tagged 1.1 versions (i.e. delivered with Geronimo 1.1) and modifying the POMs.

> > (tests fail because it can't find junit).
> 
> This might have been done with an especially prepared Ant. You either have to
> drop both ant-junit.jar (Ant task) and junit.jar (JUnit itself) into Ant
> classpaths or separate both jars from it [2]. (This seems to have changed with
> Ant 1.7.) I guess the dist was always done with junit.jar dropped into Ant's
> classpath as there is no taskdef in build.xml.

Using Ant 1.7 the build indeed works as is.

> Hmm, wait, Cocoon 2.1 uses them as well and also claims 1.3 compatibility.

Cocoon had only jta in use, but missed jca. That's why I had to do all the
things mentioned above.

> > If it helps I can tag and produce another RC (using the maven build).

It would be really fine if you (or Oliver when he is around) could create a new
dist. This works for me with both JDK 1.3 and 1.4 when using Ant 1.7. For
including all files and the XA/JTA/JCA stuff it must be distributed with JDK
1.4. The compiled stuff should be usable with JDK 1.3 though. What I tested was
a dist with 1.4 and an immediate "ant test" with 1.3 afterwards which worked (it
did not recompile the classes, only the tests).

Regards,
Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message