commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Akolkar" <rahul.akol...@gmail.com>
Subject Re: [DBCP] 1.2.2 RC1 available for review
Date Mon, 29 Jan 2007 02:49:26 GMT
On 1/28/07, Phil Steitz <phil.steitz@gmail.com> wrote:
> On 1/28/07, Henri Yandell <flamefew@gmail.com> wrote:
> >
> > On 1/28/07, Phil Steitz <phil.steitz@gmail.com> wrote:
> > > On 1/23/07, Rahul Akolkar <rahul.akolkar@gmail.com> wrote:
> > > >
<snip/>
> > > >
> > > > As nits, I'd also suggest:
> > > > * Including filename in md5s
> > > > * Building with JDK 1.3
> > >
> > >
> > > This presents a challenge, which I don't know exactly how to deal with.
> > > The  last release (1.2.1) was build with  maven using jdk 1.4.  The ant
> > > build works using 1.3, but does conditional compilation in that case to
> > > target jdbc 2.0 and also adds the jdbc 2 stdext dependency.  Could be
> > the
> > > best thing to do is to add a note in the README indicating how to build
> > > under 1.3.  Is that acceptable?
> >
> > Sounds much the same as DbUtils 1.1. It was built under 1.4 and the
> > release manager was trusted to have checked that the 1.3 build works.
> > Just in case something odd crept in JDK wise.
>
>
> I have both built and run tests on 1.3.  Just so we are clear, I assume that
> since we can't practically build [dbcp] on 1.3, I assume it is OK to build
> it using 1.5, rather than 1.4 as in the previous release.  I could cut the
> release using 1.4, but don't see the value in that.  Can anyone else?
> Thanks for the feedback.
>
<snap/>

I believe Commons libraries should take the more conservative
approach, where practically possible (I wouldn't want to cut releases
with JDK < 1.3, for example). At the end of the day, this makes the
RMs job easier.

FWIW, I feel the need to go through more rigorous testing when I pick
up a library (be it Commons or otherwise) that is built with a higher
JDK than my platform -- or I just rebuild from source, if I can.

Ultimately, this decision is upto the RM. For example, in this case, I
won't be voting against *just* because you build with JDK 1.5 (though,
FWIW, I may not vote in favor either).

-Rahul


> Phil
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message