commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz" <phil.ste...@gmail.com>
Subject Re: [nightly build] betwixt finder failed.
Date Sun, 07 Jan 2007 15:22:59 GMT
On 1/7/07, Dennis Lundberg <dennisl@apache.org> wrote:
>
> psteitz@apache.org wrote:
> > Failed build logs:
> > http://people.apache.org/~psteitz/commons-nightlies/20070107/betwixt.log
> > http://people.apache.org/~psteitz/commons-nightlies/20070107/finder.log
>
> The Maven 2 installation running the nightly builds needs to upgrade its
> jar-plugin to version 2.1, otherwise Phil's changes to the parent pom
> will cause this failure for finder or other M2 builds.


What is the best way to do that?  Wouldn't it be best to put the explicit
versioned dependency in the pom(s) that need it?  I don't like having builds
depend on local setups. I guess if its maven itself that  needs to be
upgraded we can doc that somewhere and do it, but if its a plugin, we
learned the hard way with m1 that its best to specify these in the poms.

Also, what changes to the parent are you talking about?

Thanks for looking into this.

Phil

--
> Dennis Lundberg
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message