commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nicolas de loof" <nicolas.del...@gmail.com>
Subject Re: REPOST [attributes 2.2] Missing optional package Extension
Date Thu, 04 Jan 2007 10:04:08 GMT
According to SVN log, the manifest has been added by "bayard". The maven
generated manifest is not used (why ?)

I also notice maven.compiler.target has been set to 1.4 during 2.2 (rev
410143 by leosutic) that will break backward compatibility : I'm using
commons-attributes on other projects on JRE 1.3.

I've tested some changes from commons-attributes trunk :

change maven.compiler.source and maven.compiler.target to 1.3 in
project.properties
remove manifest.mf from "api" sub-project
remove dependencies in api/project.xml (as they are only required by
compiler)

With those changes, my webapp launch fine and run as expected.

>From what I've read, Extension-List is used to allow downloading of libs at
runtime when not available in classpath. As ant and qdox manifest don't
declare themself as extensions, the extension resolution fails.

I'd suggest a new release as compatibility with 1.3 is blocking for me to
upgrade.

Nico.

2007/1/4, Henri Yandell <flamefew@gmail.com>:
>
> On 1/3/07, nicolas de loof <nicolas.deloof@gmail.com> wrote:
> > Hello,
> >
> > I'm using commons-attributes with Spring on a Java 1.4 application.
> > I've included commons-attributes-api 2.2 (from maven repo)
> >
> > I get this Tomcat exception on startup :
> > LifecycleException:  Missing optional package Extension[ant,
> > implementationURL= http://www.ibiblio.org/maven/ant/jars/ant-1.5.jar,
> > implementationVersion=1.5]
> >
> > The commons-attributes MANIFEST contains those lines :
> > Extension-List: ant qdox
> > ant-Extension-Name: ant
> > ant-Implementation-Version: 1.5
> > ant-Implementation-URL:
> http://www.ibiblio.org/maven/ant/jars/ant-1.5.jar
> > qdox-Extension-Name: qdox
> > qdox-Implementation-Version: 1.5
> > qdox-Implementation-URL:
> http://www.ibiblio.org/maven/qdox/jars/qdox-1.5.jar
> >
> >
> > I don't know what this "Extension-List" is and why is it required by
> > commons-attributes. AFAIK, the API doesn't require those libs anyway
> (only
> > the compiler do).
> >
> > Is this a bug, and what would be a workaround ?
> > AFAIK there is no development anymore on commons-attributes, so I can't
> ask
> > for a 2.2.1 to correct this. How to handle this "Extension-List" ?
> >
> > I've added ant and qodx in my WEB-INF/lib with no result.
>
> I've no idea on the specific problem you're facing, but if a solution
> turns up I could try to push out a 2.2.1 release to correct it. I
> imagine removing the bits from the manifest would solve things - have
> you tried deleting them to see if things work?
>
> That'd be my first step. Then I'd google around to see if I can figure
> out what they're for. Then either suggest a new release or a
> workaround.
>
> Hen
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message