commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton (JIRA)" <>
Subject [jira] Updated: (JXPATH-75) The dependency for xerces in commons-jxpath-1.2.pom is too old
Date Fri, 05 Jan 2007 16:09:27 GMT


Niall Pemberton updated JXPATH-75:

    Fix Version/s: 1.3

> The dependency for xerces in commons-jxpath-1.2.pom is too old
> --------------------------------------------------------------
>                 Key: JXPATH-75
>                 URL:
>             Project: Commons JXPath
>          Issue Type: Improvement
>    Affects Versions: 1.2 Final
>         Environment: java version "1.5.0_04"
> maven2
> commons-configuration-1.3
> commons-jxpath-1.2
> spring-context-2.0.1
>            Reporter: Dmitry Katsubo
>            Priority: Minor
>             Fix For: 1.3
> The following dependency in commons-jxpath-1.2.pom (see
is out-of-date:
>     <dependency>
>       <groupId>xerces</groupId>
>       <artifactId>xerces</artifactId>
>       <version>1.2.3</version>
>     </dependency>
> The side effect from this dependency is, that some component, that implicitly uses xerces,
may fail with this old xerces version. For example, I am using commons-configuration with
spring framework which assumes, that XML parser is able to make XSD verification of configuration
files, but xerces-1.2.3 is not able to do this.
> Solutions are:
> a) remove all dependencies from commons-jxpath.pom, related with xerces (I hope, most
of the community uses at least java1.5, or one may include dependency on xerces in his .pom,
as in (c) )
> b) update version of xerces in commons-jxpath.pom up to 2.4.0
> c) include dependency in your .pom, that overrides version of xerces

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message