commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <Joerg.Schai...@Elsag-Solutions.com>
Subject RE: [VOTE][VFS] release commons-vfs 1.0 based on RC10
Date Wed, 20 Dec 2006 07:46:28 GMT
Mario Ivankovits wrote on Wednesday, December 20, 2006 7:59 AM:

> Hi Jörg!
> 
>> first a question to all: Is it consensus that we use groupId
>> commons-vfs? I just wondered that it was taken for the first
>> release, since we'll switch to org.apache.commons ... 
>> 
> It's already changed for the m2 build. I don't know if its worth to
> relocate the m1.

It's just that the M1 and M2 repos are kind of mirrored. Using the groupId in one repo means
automatically the same for the M2 repo. But again, this is no stopper for the current release,
we have plenty of component to relocate after the switch :)

>> But since we have to switch/relocate a lot of projects, one more
>> does not really matter :) 
>
> ok.
> 
> 
> The ant build file is autogenerated using maven ...
>> get-dep-commons-net.jar:
>>       [get] Getting:
>> http://www.ibiblio.org/maven/commons-net/jars/commons-net-1.4.1.jar 
>> [get] To:
> /home/joehni/.maven/repository/commons-net/jars/commons-net-1.4.1.jar
>>       [get] Getting:
>> 
> This get succeeded!! Unhappily the ant build do not stop now but tries
> the other possible repositories too.

Sorry, I should have looked better myself ...

[snip]
>> 
>> Shouldn't this goal now try to download from mirrors.ibiblio.org ?
>> The fun part is, that all those deps are in my Maven 1 repo and the
>> compilation went fine afterwards ;-) 
>> 
> Hehe, yea, the ant build downloaded them fine.
> 
>> Although some tests are expected to fail, I have also a failure in
>> the VirtualProviderTestCase that makes me wonder:
>> 
> </snip>
>> ------------- ---------------- ---------------
>> Testcase:
>> 
> testSetLastModified(org.apache.commons.vfs.test.LastModifiedTe
> sts):FAILED
>> expected:<1.16656636E12> but was:<1.16656623E12>
>> junit.framework.AssertionFailedError: expected:<1.16656636E12> but
>> was:<1.16656623E12> 
>> 
> This makes me wonder too, which filesystem do you use for the test
> partition? I've tried it on two different machines both running linux
> with ext3 and
> it worked.

My Gentoo Linux is running on XFS, tests done with JDK 1.5.0.10. I will have a closer look
at the test this evening. Which JDK did you try? At least in current Win releases of JDK 5
Sun did some changes in the native FS code of the VM (longer paths than 260 chars <g>),
other changes might have happened for other native FS support code too.

- Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message