commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject [Validator] Moving to JDK 1.4 - removing the ORO Dependency
Date Thu, 07 Dec 2006 21:28:59 GMT
Now Validator 1.3.1 is released I plan to start work to remove
Validator's dependency on ORO by moving to JDK 1.4 and using its built
in regular expression support.

Nearly a year ago I ran a poll on JDK usage and validator:
    http://tinyurl.com/ybcyeh
The results of which are here:
   http://tinyurl.com/h78zf

Moving to JDK 1.4 and removing the ORO dependency has come up on the
list a number of times - and been listed as a plan for Validator 1.4
on the Jira project page for a while:
  http://issues.apache.org/jira/browse/VALIDATOR

I have created a VALIDATOR_1_3 branch in the event that there are
people willing and able to bugfix the last JDK 1.3 compatible release
(i.e. validator 1.3.1):

http://svn.apache.org/viewvc/jakarta/commons/proper/validator/branches/VALIDATOR_1_3_BRANCH/

Niall

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message