commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: Introducing commons-skin
Date Sat, 30 Dec 2006 20:42:05 GMT
Boris Unckel wrote:
> Hi,
> 
> yet another issue.

<snip>

> I had a look at the source and found XHTML transistional in the doctype.
> Both http://validator.w3.org and http://www.validome.org say it is not 
> valid.
> I think you know the tools, even when not, they are very easy to use (I 
> did not write: give good hint's for hunting the bugs).
> 
> Regards
> Boris

This turned out to be trickier than I first thought, but here goes:

1. The xdocs for commons-lang are fine.

2. Rendering of links that include the &-character, even if they are 
properly encoded as &amp; in the xdoc source, seems to be broken. That 
is the &-character doesn't get escaped properly, resulting in invalid 
xhtml. This is filed as DOXIA-85 [1].

3. The rendered documents include a css link to "css/site.css" - a file 
which doesn't exist, resulting in invalid css. This is filed as DOXIA-86 
[2].

Anyway, this doesn't involve changing commons-skin.


[1] http://jira.codehaus.org/browse/DOXIA-85
[2] http://jira.codehaus.org/browse/DOXIA-86

-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message