commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Akolkar" <rahul.akol...@gmail.com>
Subject Re: [VOTE] DbUtils 1.1
Date Fri, 01 Dec 2006 00:49:16 GMT
On 11/28/06, Henri Yandell <flamefew@gmail.com> wrote:
> On 11/28/06, Rahul Akolkar <rahul.akolkar@gmail.com> wrote:
> > On 11/28/06, Henri Yandell <flamefew@gmail.com> wrote:
> > > Apologies for another vote thread - post-thanksgiving holiday explosion.
> > >
> > > Here's the release location:
> > > http://people.apache.org/~bayard/commons-dbutils/1.1-RC2/
> > >
> > <snip/>
> >
> > Doesn't build with 1.3 as advertised, javax.sql.DataSource is JDK 1.4
>
> Yep, the Ant gives out a warning that you need to put the
> jdbc-optional-ext jar in the lib/ directory if on 1.3.
>
<snip/>

+1 to the release.

The m1 build is broken on 1.3. OK with that being a "known issue"
since the correct solution for the m1 build would be along the lines
of:

  <dependency>
    <groupId>javax.sql</groupId>
    <artifactId>jdbc-stdext</artifactId>
    <version>2.0</version>
    <url>http://java.sun.com/products/jdbc/</url>
    <properties>
      <optional>true</optional>
      <comment>
        &lt;strong&gt;JDK 1.3 only&lt;/strong&gt;.
      </comment>
    </properties>
  </dependency>

which requires coping with that jar [1], and that will probably break
more m1 builds (>1.3) than it will fix. About when m2 profiles look
pleasing.

-Rahul

[1] http://maven.apache.org/guides/mini/guide-coping-with-sun-jars.html


>
> Hen
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message