commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: [Digester] Maven2 POM Questions and Proposals
Date Thu, 16 Nov 2006 23:50:18 GMT
Craig McClanahan wrote:
> On 11/16/06, Dennis Lundberg <dennisl@apache.org> wrote:
>>
>> Simon Kitching wrote:
>> > On Wed, 2006-11-15 at 22:20 -0500, Rahul Akolkar wrote:
>> >> On 11/14/06, Dennis Lundberg <dennisl@apache.org> wrote:
>> >
>> >>> I was going to try it myself but I get a test failure, see below, 
>> so I
>> >>> haven't been able to try it myself.
>> >>>
>> >>>
>> >>>
>> ------------------------------------------------------------------------------- 
>>
>> >>> Test set: org.apache.commons.digester.NodeCreateRuleTestCase
>> >>>
>> ------------------------------------------------------------------------------- 
>>
>> >>> Tests run: 9, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.062
>> >>> sec <<< FAILURE!
>> >>> testNonNamespacedAttribute(
>> org.apache.commons.digester.NodeCreateRuleTestCase)
>> >>>   Time elapsed: 0 sec  <<< FAILURE!
>> >>> junit.framework.AssertionFailedError
>> >>>         at junit.framework.Assert.fail(Assert.java:47)
>> >>>         at junit.framework.Assert.assertTrue(Assert.java:20)
>> >>>         at junit.framework.Assert.assertNotNull(Assert.java:220)
>> >>>         at junit.framework.Assert.assertNotNull(Assert.java:213)
>> >>>         at
>> >>>
>> org.apache.commons.digester.NodeCreateRuleTestCase.testNonNamespacedAttribute 
>>
>> (NodeCreateRuleTestCase.java:437)
>> >>>
>> >> <snip/>
>> >>
>> >> Hmm, cannot reproduce the failure locally. The nightlies seem to be
>> >> happy too (though they're running the test under m1). Any more details
>> >> about your setup or other clues?
>> >
>> > Works for me too (Sun java 1.5.0 on Linux).
>> >
>> > Initially it would look like the xml parser in use is behaving
>> > differently from what most people get.
>> >
>> > What JVM are you using - not gcj by any chance?
>> >
>> > Cheers,
>> >
>> > Simon
>>
>> I'm running Sun Java 1.4.2_13 on Win XP.
>> Will investigate some more...
> 
> 
> Works for me as well (Sun Java 1.5.0_09 on Win XP).
> 
> Craig

This is most peculiar!

I installed Sun Java 1.5.0_09 ant ran
   mvn test
and it works just fine.

If I run with 1.4.2_13 it fails.

If I use Maven 1 with 1.4.2_13 like this
   maven test
it also works.

-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message