commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas DE LOOF <nicolas.del...@capgemini.com>
Subject Re: [dbutils] Preparing the 1.1 release
Date Wed, 15 Nov 2006 07:57:14 GMT

Sorry, I didn't read the beginning of this thread.

Do you want to create an Ant build only to ensure compilation for Java 
1.3 runtime ?
I'm doing the same with maven by setting the compiler plugin to use JRE 
1.3 rt.jar as bootclasspath. I've made some tests to ensure this 
produces java 1.3 compliant code and doesn't link classes to methods 
introduced in Java 1.4/Java5.

Nico.

Dennis Lundberg a écrit :
> Henri Yandell wrote:
>> Ideally I'd want to use Ant to build the dist under 1.3 and then use
>> Maven to generate the site under 1.5. I'd use 1.2, but I'm not setup
>> for that at the moment.
>>
>> In this case, I want to use Maven to do everything under 1.4 and point
>> to the fact that Ant works under 1.3 to build a jar/test as
>> justification that it's okay to do it under 1.4. My personal
>> justifcation for the Ant files is that Maven-1 doesn't work under
>> 1.2/1.3, so I'm a bit low personal itch-wise for implementing lots of
>> stuff in the Ant files.
>
> +1
>

This message contains information that may be privileged or confidential and is the property
of the Capgemini Group. It is intended only for the person to whom it is addressed. If you
are not the intended recipient,  you are not authorized to read, print, retain, copy, disseminate,
 distribute, or use this message or any part thereof. If you receive this  message in error,
please notify the sender immediately and delete all  copies of this message.


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message