commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yury Litvinov (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DAEMON-87) procrun as tomcat5.exe from Tomcat 5.5.17 does not start, when installed into the file path containing non-ascii character
Date Thu, 28 Sep 2006 23:53:51 GMT
     [ http://issues.apache.org/jira/browse/DAEMON-87?page=all ]

Yury Litvinov updated DAEMON-87:
--------------------------------

    Attachment: apxwin.h

Modifed original file  prunsrv\include\apxwin.h. Contains function declarations implemented
into utils.h. Please use 'DAEMON-87' to grep changes quickly.

> procrun as tomcat5.exe from Tomcat 5.5.17 does not start, when installed into the file
path containing non-ascii character
> --------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DAEMON-87
>                 URL: http://issues.apache.org/jira/browse/DAEMON-87
>             Project: Commons Daemon
>          Issue Type: Bug
>            Reporter: Yury Litvinov
>         Attachments: apxwin.h, prunsrv.c, utils.c
>
>
> Tomcat Service can not be started if Tomcat was installed into the path, 
> containing non-ASCII (e.g. Japanese or Chinese) symbols.
> The problem is apparently due to the improper treatment of non-ascii 
> characters in the "Java classpath" section of the Service settings.
> In tomcat5w.exe GUI or windows registry I could see proper PATH, namely
> C:\[ONE CHINESE HIEROGLIPH]\Tomcat 5.5\bin\bootstrap.jar
> Unfortunately, service doesn't get started with the following log:
> [2006-09-15 18:29:17] [457  javajni.c] [error] FindClass 
> org/apache/catalina/startup/Bootstrap failed
> [2006-09-15 18:29:17] [935  prunsrv.c] [error] Failed loading main 
> org/apache/catalina/startup/Bootstrap class C:\ss\Tomcat 5.5\bin\bootstrap.jar
> [2006-09-15 18:29:17] [1179 prunsrv.c] [error] ServiceStart returned 3
> where the non-ascii symbol gets replaced with improper ascii 'ss' sequence.
> Moreover, I tried to define environmental variables PR_CLASSPATH and 
> PR_STARTPATH instead of using corresponding service params. The result is 
> exactly the same.
> Please, suggest me the workaround to make Tomcat service run.
> P.S. The problem is stable either under JRE 1.5.0_02 or 1.4.2_10 (within 
> tomcat compatibility package). The problem exist apparently under all OS (in 
> particular, it was detected on Windows 2000 and Windows XP Pro 2002 SP2 either 
> Chinese version or standard English with Chinese System locale installed.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message