commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: [openpgp] mvn site errors
Date Sat, 05 Aug 2006 18:21:37 GMT
Henri Yandell wrote:
> When I try to generate the openpgp site I get the following error:
> 
> 
> [INFO] [site:site]
> [INFO] 
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Error parsing site descriptor
> 
> Embedded error: expected START_TAG or END_TAG not TEXT (position: TEXT
> seen ...ndbox"                  href="/">\n        ${modulesItems}\n
>   </... @71:9)
> 
> 
> I'm using Maven 2.0.4 on a Mac.
> 
> It appears to be being caused by the following in src/site/site.xml:
> 
>      <item name="Sandbox"                  href="/">
>        ${modulesItems}
>      </item>
> 
> Hen

I committed a fix for this in r429022. It is not perfect for a couple of 
reasons, which I describe in an earlier mail on the maven list [1].

There is also a bug [2] in the site-plugin. It doesn't pick up the name 
(Sandbox components) for the modules menu. I'll try to fix that.

[1]http://mail-archives.apache.org/mod_mbox/maven-dev/200605.mbox/%3C44670608.80402@apache.org%3E
[2]http://jira.codehaus.org/browse/MSITE-137

-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message