commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell" <flame...@gmail.com>
Subject [jci] mvn errors
Date Sat, 05 Aug 2006 03:50:57 GMT
When building using 'mvn package' I get:

Running org.apache.maven.plugin.JCIMojoTestCase
[debug] javac
java.lang.InstantiationException:
org.apache.commons.jci.compilers.JavacJavaCompiler
        at java.lang.Class.newInstance0(Class.java:335)
        at java.lang.Class.newInstance(Class.java:303)
        at org.apache.commons.jci.compilers.JavaCompilerFactory.createCompiler(JavaCompilerFactory.java:79)
        at org.apache.maven.plugin.AbstractJCIMojo.execute(AbstractJCIMojo.java:56)



When trying to build the site using 'mvn site' I get:

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.apache.commons:commons-jci-javac:jar:1.0-SNAPSHOT
<snip>
---------
1 required artifact is missing.

for artifact:
  org.apache.commons:maven-jci-plugin:maven-plugin:1.0-SNAPSHOT

from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  apache-snapshots (http://people.apache.org/maven-snapshot-repository),
  codehaus-snapshot (http://snapshots.maven.codehaus.org/maven2)

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message