commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: [modeler] 2.0 RC1 ready for review (Re: [modeler] RC2 for Commons Modeler)
Date Fri, 21 Jul 2006 21:05:11 GMT
Looks good to me. Only one thing I noticed - maybe need to flag some
of the dependencies in the project.xml so that if/when a maven2 pom is
generated.

I'm guessing that it doesn't require mx4j specifically - presumably
any JMX implementation so should this be marked as "provided"?

Also the "xml-apis" I assume is for JDK 1.3 and not necessary for JDK
1.4+ so maybe optional?

I had similar things after the Chain 1.1 release with Struts getting
unecessary addtional dependencies pulled in by m2.

Niall

P.S. If you decide to make these changes its not necessary IMO to cut
another RC.

On 7/21/06, Davanum Srinivas <davanum@gmail.com> wrote:
> One more rev folks..Changed the version to 2.0 because of the
> incompatible api change. Also please note that the minimum jdk version
> is 1.3.
>
> http://people.apache.org/~dims/commons-modeler-2.0-RC1/
>
> thanks,
> dims
>
> On 7/20/06, Davanum Srinivas <davanum@gmail.com> wrote:
> > OK. Will cut a 2.0-RC1 is there are no objections.
> >
> > thanks,
> > dims
> >
> > On 7/20/06, Henri Yandell <flamefew@gmail.com> wrote:
> > > Checked:
> > >
> > > * PGP and md5's check out using KEYS.txt from svn. Bit odd that Remy
> > > is the name listed on the dist KEYS, but Yoav and yourself are the
> > > ones in svn. Be careful not to lose Remy's entry.
> > >
> > > * tar.gz's match zips.
> > >
> > > * src buids under maven.
> > >
> > > Negatives:
> > >
> > > * Stephen's point about 2.0 if it's an incompatible API change.
> > > * Need an entry for 1.2 on
> > > http://people.apache.org/~dims/commons-modeler-1.2rc2/site/downloads.html
> > > * There's an entry on the front page to the package description. It
> > > uses an absolute url.
> > >
> > > I've fixed the last two - for the download one I put 2.0 as the
> > > version so if there's disagrement on 1.2->2.0 that'll need to change
> > > back.
> > >
> > > Hen
> > >
> > > On 7/19/06, Davanum Srinivas <davanum@gmail.com> wrote:
> > > > Hi Team,
> > > >
> > > > Here's the new cut of commons modeler (RC2):
> > > > http://people.apache.org/~dims/commons-modeler-1.2rc2/
> > > >
> > > > I've tried to incorporate all the feedback so far. So, please kick the
> > > > tires and send some more :)
> > > >
> > > > thanks,
> > > > dims

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message