commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: [Modeler] Resync and Release for commons-modeler
Date Mon, 05 Jun 2006 02:46:52 GMT
As I remarked in http://svn.apache.org/viewvc?rev=411629&view=rev, resyncing 
with Tomcat's version of Modeler will never get accepted by the Tomcat team 
for TC 5.x.  However, I promise to patch TC5 to fix MODELER-15 once it is 
decided to upgrade.  MODELER-17 is fixed now (but I lack karma to mark it as 
such :).  I consider MODELER-10 to be INVALID (for reasons explained there, 
but again, there is that karma thing :).  I consider MODELER-3 to be 
assigned to Dennis.  MODELER-2 is already fixed, but just not marked as 
such.  I lack karma to fix MODELER-6, and really don't care all that much.

That pretty much covers the state of open issues with [modeler].  Once 
Dennis has committed his patch, I see no reason for somebody not to step up 
and RM a [VOTE].

"Bill Barker" <wbarker@wilshire.com> wrote in message 
news:e5vc06$onj$1@sea.gmane.org...
>
> "Dennis Lundberg" <dennisl@apache.org> wrote in message 
> news:4482A586.4090108@apache.org...
>> Davanum Srinivas wrote:
>>> Bill, Yoav, Dennis,
>>> Could you please help with [1] and the resync with Tomcat's version of
>>> modeler? Once that is done, rbb and/or i can start a VOTE thread for a
>>> release that we need for Geronimo.
>>>
>>> Thanks,
>>> dims
>>>
>>> [1] http://issues.apache.org/jira/browse/MODELER-3
>>
>> Like I said in that JIRA-issue, and the thread on general [2], it all 
>> depends on what minimum Java version we want for modeler. If we are OK 
>> with 1.3 I can go ahead and fix [1].
>>
>
> It's only a POM change, so I really don't care (I never use the POM, and 
> Tomcat doesn't even use Maven :).  In fact, the Ant build defaults to 
> using the JMX RI.  If the user really wants to use a 1.2 JVM, all they 
> would have to do is to swap out the JMX implementation.
>
>> But, since I am not a modeler user myself, I really cannot say which Java 
>> version is OK to use. That should be up to the current users of modeler, 
>> which seems to be Geronimo and Tomcat.
>>
>> [2]http://mail-archives.apache.org/mod_mbox/jakarta-general/200605.mbox/%3c9A23736F-07D4-4769-9C2E-A809DFFC12D0@apache.org%3e
>>
>> -- 
>> Dennis Lundberg 




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message