commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <>
Subject Re: [configuration][all] Maven 2 repository
Date Sat, 24 Jun 2006 15:55:17 GMT
Oliver Heger wrote:
> Hi all,
> the following bug report came in for [configuration] 
> (
> <cite>
> As described by ASF bug #33476 Commons Configurations shall depend on 
> Servlet-API 2.4. The current Maven2 POM of Commons Configuration 1.2 
> shows a dependency on Servlet-API 2.3. This is not only a mismatch 
> between Commons Configurations' build configuration and its Maven2 POM 
> but also prevents Maven2 projects from using the Servlet-API 2.4 if also 
> using Commons Configuration 1.2.
> Could it be possible to fix Commons Configuration 1.2's Maven2 POM to 
> include a dependency on Servlet-API 2.4, please?
> </cite>
> Unfortunately I am no maven 2 expert. I assume the maven 2 POM is 
> automatically generated from the maven 1 POM, is it?

Yes it is.

> What can be done to fix this problem?

The Maven community has decided to not change POMs that has already been 
deployed to the repository. This is a recent change in policy. It was 
made to ensure reproducible builds. What we can do is to fix any 
problems in the next release of configuration.

Having had a look at build.xml and project.xml for the current SVN trunk 
of configuration, I must say that I do not understand what the author of 
the issue means. Both files indicate a dependency on servletapi-2.3. The 
bugzilla issue does mention servlet-api-2.4, but that patch was never 
applied. So in my eyes there is no problem.

Dennis Lundberg

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message