commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jochen Wiedmann (JIRA)" <>
Subject [jira] Updated: (FILEUPLOAD-109) MultipartStream.discardBodyData() implementation is redundant.
Date Mon, 22 May 2006 12:49:30 GMT
     [ ]

Jochen Wiedmann updated FILEUPLOAD-109:

    Attachment: commons-fileupload-1.patch

Funny, but I came to the same conclusion just yesterday. In case someone's interested, here's
my version with the check for null. (Which I personally prefer, because I believe it has less

> MultipartStream.discardBodyData()  implementation is redundant.
> ---------------------------------------------------------------
>          Key: FILEUPLOAD-109
>          URL:
>      Project: Commons FileUpload
>         Type: Improvement

>     Versions: 1.1 Final
>     Reporter: Amichai Rothman
>     Priority: Minor
>  Attachments: commons-fileupload-1.1-bug-109.patch, commons-fileupload-1.patch
> MultipartStream.discardBodyData() is identical to readBodyData() - copied and pasted,
but with output removed.
> discardBodyData() can be changed to call readBodyData() with a NullInputStream (from
commons io package, which is already a dependency). This is much more readable and maintainable,
and much less error prone.
> (Alternatively, readBodyData() can be modified to handle a null output stream by performing
a null check before writing into it, and skipping the writes if output is null. then discardBodyData()
can call it with a null argument. However, the first solution seems more elegant.)

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message