commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Benson <gudnabr...@yahoo.com>
Subject Re: [attributes] building with maven
Date Mon, 03 Apr 2006 16:29:13 GMT
This did indeed seem to solve my problem with the
install goal.  The instruction say to run
install-plugin and test as well; these attempt to DL
[ca] but fail.  I will continue to investigate
whether/how I can (simply) test my local [ca] build.

Thanks Phil,
Matt

--- Phil Steitz <phil.steitz@gmail.com> wrote:

> For some reason the javadoc-1.4 dependency in the
> /compiler POM is
> commented out.  When I remove the comments around
> 
> <dependency>
>   <groupId>javadoc</groupId>
>    <artifactId>javadoc</artifactId>
>    <version>1.4</version>
> </dependency>
> 
> in /compiler/project.xml the build succeeds for me. 
> Don't know if
> this is the right solution, but it eliminates the
> compile failures
> that I was seeing due to missing javadoc classes.
> 
> Phil
> 
> On 4/2/06, Leo Sutic <leo.sutic@gmail.com> wrote:
> > Hi Matt,
> >
> > I'm currently away from any kind of build
> environment, so I can't
> > replicate your problems (it built fine for me last
> time I tried,
> > though). Could you post the full Maven output, and
> could you run maven
> > with the -v (verbose) switch? I'll attack the
> problem from this end,
> > as much and fast as I can.
> >
> > Sorry that C.A is causing you problems. I
> definitely intended for it
> > to be a dirt-simple check-out-and-build-and-use.
> >
> > /LS
> >
> > On 3/31/06, Matt Benson <gudnabrsam@yahoo.com>
> wrote:
> > > I am attempting to build C.A.  What I have
> figured out
> > > by trial and error so far:
> > >
> > > - install maven 1.0.2
> > > - co commons-attributes and commons-build
> side-by-side
> > > - in /commons-attributes, run 'maven install'.
> > >
> > > It goes through retrieving dependencies and
> placing
> > > these all in a maven repo.  This includes the
> javadoc
> > > jar
> > >
>
($HOME/.maven/repository/javadoc/jars/javadoc-1.4.jar).
> > >  The C.A. api builds fine, but when the compiler
> tries
> > > to build, the classes and even the packages in
> the
> > > javadoc jar are not found and the build fails.
> > >
> > > Does anyone have any advice to get further?
> > >
> > > Thanks,
> > > Matt
> > >
> > >
> __________________________________________________
> > > Do You Yahoo!?
> > > Tired of spam?  Yahoo! Mail has the best spam
> protection around
> > > http://mail.yahoo.com
> > >
> > >
>
---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
> commons-dev-unsubscribe@jakarta.apache.org
> > > For additional commands, e-mail:
> commons-dev-help@jakarta.apache.org
> > >
> > >
> >
> >
>
---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> commons-dev-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail:
> commons-dev-help@jakarta.apache.org
> >
> >
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> commons-dev-help@jakarta.apache.org
> 
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message