commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [VOTE] Release Validator 1.3.0 based on RC2
Date Mon, 20 Mar 2006 22:50:59 GMT
Niall Pemberton wrote:

> On 3/20/06, Niall Pemberton <niall.pemberton@gmail.com> wrote:
[snip]
>> > Happy to do that.  I will be out of pocket for the next 10 hrs or so,
>> > but will be happy to help later this eve (US EST).  I will do some
>> > more investigating tonight.  Has anyone else tested on Linux?
>>
>> Thanks Phil appreciate the assistance. I've had a thought on this -
>> I've used the UK Pound symbol (£) in my JUnit test case - but its not
>> part of the standard ASCII character set like $ is and I think this is
>> might be where the problem lies. I'm going to replace this to get the
>> UK currenecy symbol from DecimalFormatSymbols (rather than hard coding
>> in the java JUnit test). I'll post a test version for you to download
>> and run.
> 
> OK I've created a test version which I'm hoping will resolve this,
> source distros available here:
> 
> http://people.apache.org/~niallp/validator-1.3.0-PHIL/
> 
> Should just need to run "maven test" to verify if this has cured the
> problem.

Funny:

[snip]
...
    [junit] Running org.apache.commons.validator.ValidatorResultsTest
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.282 sec
    [junit] Running org.apache.commons.validator.DateTest
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.277 sec
    [junit] Running org.apache.commons.validator.ValidatorTest
ValidatorTest.formatDate() - Unparseable date: "2/30/1999"
    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.134 sec
    [junit] Running org.apache.commons.validator.ISBNValidatorTest
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.049 sec
    [junit] Running org.apache.commons.validator.FloatTest
    [junit] Tests run: 6, Failures: 0, Errors: 0, Time elapsed: 0.446 sec
    [junit] Running org.apache.commons.validator.GenericValidatorTest
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.015 sec
    [junit] Running org.apache.commons.validator.EntityImportTest
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.244 sec
    [junit] Running org.apache.commons.validator.RetrieveFormTest
Form 'INVALID_NAME' not found for locale 'en_US'
Form 'INVALID_NAME' not found for locale 'fr'
Form 'INVALID_NAME' not found for locale 'fr_FR'
Form 'INVALID_NAME' not found for locale 'en_CA'
Form 'INVALID_NAME' not found for locale 'fr_CA'
Form 'INVALID_NAME' not found for locale 'fr_CA_XXX'
    [junit] Tests run: 5, Failures: 0, Errors: 0, Time elapsed: 0.374 sec
    [junit] Running org.apache.commons.validator.LocaleTest
    [junit] Tests run: 5, Failures: 0, Errors: 0, Time elapsed: 0.37 sec
    [junit] Running org.apache.commons.validator.ExceptionTest
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.231 sec
    [junit] Running org.apache.commons.validator.EmailTest
    [junit] Tests run: 8, Failures: 0, Errors: 0, Time elapsed: 0.814 sec
    [junit] Running org.apache.commons.validator.LongTest
    [junit] Tests run: 8, Failures: 0, Errors: 0, Time elapsed: 0.478 sec
    [junit] Running org.apache.commons.validator.FieldTest
    [junit] Tests run: 9, Failures: 0, Errors: 0, Time elapsed: 0.014 sec
BUILD SUCCESSFUL
Total time: 36 seconds
Finished at: Mon Mar 20 23:44:26 CET 2006


Test succeeds, but get those strange messages on console. Running Gentoo,
Sun JDK 1.4.2 with German locale. Tested with current trunk, Phil's and
Oliver's version, all behave the same for me.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message