commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Gregory" <ggreg...@seagullsoftware.com>
Subject RE: [VOTE] Release Commons IO 1.2 (based on RC3)
Date Sun, 12 Mar 2006 20:44:05 GMT
Based on RC4:

I can do a Maven build with Sun Java 1.4.2_10 on Windows XP SP2.

I get a Maven build failure using Java 1.3.1_15 (See below).

It tuens out that Cobertura requires Java 1.4:

"Also, Cobertura 1.2 (and 1.1, and maybe 1.0) requires a 1.4 or newer
JVM."

The above is from the 16 March 2005 entry on
http://cobertura.sourceforge.net/ 

So we should note that on the build page. I think it is OK to require
1.4 to build while leaving the runtime requirement to be 1.2 or 1.3. Of
course this is then tricky to test... arg.

cobertura:report-internal:
    [cobertura-report] Cobertura 1.6 - GNU GPL License (NO WARRANTY) -
See COPYRIGHT file
    [cobertura-report] java.lang.NoSuchMethodError
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.html.JavaToHtml.processLine(JavaToHt
ml.java:261)
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.html.JavaToHtml.process(JavaToHtml.j
ava:136)
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.html.HTMLReport.generateSourceFile(H
TMLReport.java:509)
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.html.HTMLReport.generateSourceFiles(
HTMLReport.java:404)
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.html.HTMLReport.<init>(HTMLReport.ja
va:81)
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.Main.parseArguments(Main.java:100)
    [cobertura-report]  at
net.sourceforge.cobertura.reporting.Main.main(Main.java:161)
    [cobertura-report] Exception in thread "main"
org.apache.commons.jelly.JellyTagException: C:\Documents and
Settings\ggregory.SSSI\.maven\cache\maven-cobertura-plugin-1.1.1\plugin.
jelly:308:81: <ant:cobertura-report> Error running reports. S
ee messages above.

BUILD FAILED
File...... C:\Documents and
Settings\ggregory.SSSI\.maven\cache\maven-cobertura-plugin-1.1.1\plugin.
jelly
Element... ant:fail
Line...... 282
Column.... 39
org.apache.commons.jelly.JellyTagException: C:\Documents and
Settings\ggregory.SSSI\.maven\cache\maven-cobertura-plugin-1.1.1\plugin.
jelly:308:81: <ant:cobertura-report> Error running reports. S
ee messages above.
Total time: 1 minutes 50 seconds
Finished at: Sun Mar 12 12:36:57 PST 2006


> -----Original Message-----
> From: Stephen Colebourne [mailto:scolebourne@btopenworld.com]
> Sent: Saturday, March 11, 2006 2:13 PM
> To: Jakarta Commons Developers List
> Subject: [VOTE] Release Commons IO 1.2 (based on RC3)
> 
> This is a vote for the release [io] v1.2 based on RC3
> 
> It's a new vote for clarity:
> - download doesn't depend on commons-build (Gary)
> - some tests patched (Niall)
> - building.html linked to commons building page (Gary)
> - MD5 and ASC for jar available (Robert)
> - various scripts changed to support above
> 
> RC3 is here:
> http://people.apache.org/~scolebourne/commons-io/
> 
> Site here:
> http://people.apache.org/~scolebourne/commons-io/site/
> 
> Release notes here:
>
http://people.apache.org/~scolebourne/commons-io/site/upgradeto1_2.html
> 
> ------------
> [ ] +1  I support this release
> [ ] +0
> [ ] -0
> [ ] -1  I do not support this release because...
> ------------
> 
> Stephen
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message